Worknice - Application is unresponsive – Incident details
Report an issue
Get updates
Email
SMS
Google Chat
API
Report an issue
Get updates
Dark mode
All systems operational
Application is unresponsive
Resolved
Major outage
Started 2 months ago
Lasted 10 minutes
Affected
app.worknice.com
Major outage from 12:48 AM to 12:58 AM
Updates
Resolved
August 01, 2025 at 12:58 AM
Resolved
August 01, 2025 at 12:58 AM
This incident has been resolved.
Monitoring
August 01, 2025 at 12:54 AM
Monitoring
August 01, 2025 at 12:54 AM
We implemented a fix and are currently monitoring the result.
Investigating
August 01, 2025 at 12:48 AM
Investigating
August 01, 2025 at 12:48 AM
We are currently investigating this incident.